Excel: формула вывода среднего числа
+ Ответить в теме
Показано с 1 по 6 из 6
Тема: 

Excel: формула вывода среднего числа

  1. #1
    «CSS-ARMY»
    руководитель клана
    Аватар для ๖ۣۜЧۼćŃờĶۣۜ
    ๖ۣۜЧۼćŃờĶۣۜ вне форума

    Регистрация
    17.05.2011
    Возраст
    31
    Сообщений
    131
    Лицензия
    steam
    Участник
    RUS-CSS-ARMY
    Репутация
    127
    Кто разбирается в вычислениях Excel?

    Мне нужна формула вывода среднего числа в столбце, где есть прочерки вместо значений, так вот, вместо этих прочерков нужно, чтобы автоматом считалось как бы значение 100. Это возможно?

    Пример: example.zip

    Тупо поставить вместо прочерка значение 100 не является решением.

  2. #2
    I love CS:S Аватар для VerZila
    VerZila вне форума

    Регистрация
    03.05.2012
    Сообщений
    444
    Лицензия
    steam
    Участник
    RUS-CSS-ARMY
    Репутация
    159
    А если добавить столбец и заполнить его формулой =ЕСЛИ(A1="-";100;A1), а столбец А скрыть? Т.е использовать добавленный столбец в качестве столбца А.
    Я конечно еще подумаю, как сделать проще...

    ---------- Добавлено позже ----------

    А можно наоборот скрыть добавленный столбец, а среднее значение под столбцом А брать из добавленного столбца. Так в столбец А можно будет добавлять строки.
    Память остается, даже когда отбирают все остальное.

  3. #3
    «CSS-ARMY»
    руководитель клана
    Аватар для ๖ۣۜЧۼćŃờĶۣۜ
    ๖ۣۜЧۼćŃờĶۣۜ вне форума

    Регистрация
    17.05.2011
    Возраст
    31
    Сообщений
    131
    Лицензия
    steam
    Участник
    RUS-CSS-ARMY
    Репутация
    127
    Них не понимаю)) ты можешь отразить это в файле примера?

  4. #4
    I love CS:S Аватар для VerZila
    VerZila вне форума

    Регистрация
    03.05.2012
    Сообщений
    444
    Лицензия
    steam
    Участник
    RUS-CSS-ARMY
    Репутация
    159
    Вот example0.rar.
    Память остается, даже когда отбирают все остальное.

  5. #5
    «CSS-ARMY»
    руководитель клана
    Аватар для ๖ۣۜЧۼćŃờĶۣۜ
    ๖ۣۜЧۼćŃờĶۣۜ вне форума

    Регистрация
    17.05.2011
    Возраст
    31
    Сообщений
    131
    Лицензия
    steam
    Участник
    RUS-CSS-ARMY
    Репутация
    127
    Ну так мне нужна формула, где там формула то? В первом столбце, в последней ячейке, где выводится среднее значение, должа быть формула, а тебя там пусто.

  6. #6
    I love CS:S Аватар для VerZila
    VerZila вне форума

    Регистрация
    03.05.2012
    Сообщений
    444
    Лицензия
    steam
    Участник
    RUS-CSS-ARMY
    Репутация
    159
    Во втором столбце посмотри на ячейки с данными, там забита формула =ЕСЛИ(A1="-";100;A1) смены прочерков на 100, а в нижу столбца В подсчитывается среднее значение. А в конце столбца А среднее значение берется из В. если ты будешь добавлять строки ниже и добавлять в столбце А данные, то ср.значение в ст. В будет меняться и соответственно в ст. А тоже.
    Не было времени сегодня сделать одну формулу для вычисления без дополнительного столбца.
    Память остается, даже когда отбирают все остальное.

+ Ответить в теме

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

     

Ваши права

  • Вы можете создавать новые темы
  • Вы можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения